LangflowPublished 29 Oct 2026NVD status: Analyzed

CVE-2026-90991

IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to cause a denial of service due to allocation of resources without limits or throttling.

ComponentLangflow
Severitymedium (CVSS 6.5)
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Published (NVD)2026-10-29
Last modified2026-10-30
Affected versions
>= 1.0.0, < 1.12.5
Fixed in1.12.5
WeaknessCWE-770
CISA KEVnot listed

Versions, checked against NVD

These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.

NVD description

IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to cause a denial of service due to allocation of resources without limits or throttling.

What to do

  • Upgrade Langflow to 1.12.5 or later.
  • Do not expose the component's API or UI to the internet without authentication in front of it.

Sources

Read more