| Component | Langflow |
| Severity | medium (CVSS 6.5) |
| CVSS vector | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H |
| Published (NVD) | 2026-10-29 |
| Last modified | 2026-10-30 |
| Affected versions | >= 1.0.0, < 1.12.4 |
| Fixed in | 1.12.4 |
| Weakness | CWE-285 |
| CISA KEV | not listed |
Versions, checked against NVD
These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.
NVD description
IBM Langflow OSS 1.0.0 through 1.12.3 could allow an authenticated attacker to cancel any victim's running background workflow job by sending a single HTTP request, resulting in loss of in-progress compute work with no flow-level permission check.
What to do
- Upgrade Langflow to
1.12.4or later. - Do not expose the component's API or UI to the internet without authentication in front of it.