| Component | Langflow |
| Severity | high (CVSS 8.1) |
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H |
| Published (NVD) | 2026-10-29 |
| Last modified | 2026-10-30 |
| Affected versions | >= 1.0.0, < 1.12.4 |
| Fixed in | 1.12.4 |
| Weakness | CWE-502 |
| CISA KEV | not listed |
Versions, checked against NVD
These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.
NVD description
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could reach the message broker to execute arbitrary code on the system due to the deserialization of untrusted data.
What to do
- Upgrade Langflow to
1.12.4or later. - Do not expose the component's API or UI to the internet without authentication in front of it.