LangflowPublished 29 Oct 2026NVD status: Analyzed

CVE-2026-104331

IBM Langflow OSS 1.0.0 through 1.12.3 is vulnerable to server-side request forgery (SSRF).

ComponentLangflow
Severitymedium (CVSS 5.4)
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Published (NVD)2026-10-29
Last modified2026-10-30
Affected versions
>= 1.0.0, < 1.12.4
Fixed in1.12.4
WeaknessCWE-918
CISA KEVnot listed

Versions, checked against NVD

These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.

NVD description

IBM Langflow OSS 1.0.0 through 1.12.3 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks.

What to do

  • Upgrade Langflow to 1.12.4 or later.
  • Do not expose the component's API or UI to the internet without authentication in front of it.

Sources

Read more