LangflowPublished 29 Oct 2026NVD status: Analyzed

CVE-2026-110186

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.

ComponentLangflow
Severitycritical (CVSS 9.8)
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published (NVD)2026-10-29
Last modified2026-10-30
Affected versions
>= 1.0.0, < 1.13.0
Fixed in1.13.0
WeaknessCWE-94
CISA KEVnot listed

Versions, checked against NVD

These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.

NVD description

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.

What to do

  • Upgrade Langflow to 1.13.0 or later.
  • Do not expose the component's API or UI to the internet without authentication in front of it.

Sources

Read more