| Component | Langflow |
| Severity | high (CVSS 8.8) |
| CVSS vector | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
| Published (NVD) | 2026-10-29 |
| Last modified | 2026-10-30 |
| Affected versions | >= 1.0.0, < 1.13.0 |
| Fixed in | 1.13.0 |
| Weakness | CWE-94 |
| CISA KEV | not listed |
Versions, checked against NVD
These are NVD's ranges. Neither a GitHub-reviewed advisory nor the CVE record gives versions to check them against yet.
NVD description
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.
What to do
- Upgrade Langflow to
1.13.0or later. - Do not expose the component's API or UI to the internet without authentication in front of it.