| Component | vLLM |
| Severity | high (CVSS 8.1) |
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H |
| Published (NVD) | 2026-10-26 |
| Affected versions | < 0.32.0 >= 12.0.0, <= 12.2.0 read from the advisory text, followed where the structured sources say otherwise |
| Fixed in | 0.32.0 |
| Weakness | CWE-20CWE-183 |
| CISA KEV | not listed |
NVD description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
What to do
- Upgrade vLLM to
0.32.0or later. - Do not expose the component's API or UI to the internet without authentication in front of it.
Sources
- NVD: CVE-2026-115915
- https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
- https://github.com/vllm-project/vllm/pull/60022
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h