| Component | vLLM |
| Severity | low (CVSS 3.4) |
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N |
| Published (NVD) | 2026-10-26 |
| Affected versions | < 0.32.0 from the CVE Program record written by the CNA that assigned the CVE |
| Fixed in | 0.32.0 |
| Weakness | CWE-942 |
| CISA KEV | not listed |
NVD description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
What to do
- Upgrade vLLM to
0.32.0or later. - Do not expose the component's API or UI to the internet without authentication in front of it.
Sources
- NVD: CVE-2026-115917
- https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
- https://github.com/vllm-project/vllm/pull/61009
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh