| Component | n8n |
| Severity | high (CVSS 7.1) |
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N |
| Published (NVD) | 2026-10-28 |
| Affected versions | < 1.123.85 >= 2.0.0, < 2.43.5 >= 2.44.0, < 2.44.1 from the CVE Program record written by the CNA that assigned the CVE |
| Fixed in | 1.123.85, 2.43.5, 2.44.1 |
| Weakness | CWE-863 |
| CISA KEV | not listed |
Versions, checked against NVD
NVD's record (status: Deferred) lists no affected versions of n8n for this CVE. The ranges above come from the CVE record written by VulnCheck, the CNA that assigned the CVE.
NVD description
n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability that allows member users to use credentials they cannot access by omitting default node parameters. Attackers can save and run workflows where pre-execution checks skip credential slots, causing decrypted credential values to be sent to attacker-chosen destinations.
What to do
- Upgrade n8n to the fixed release of the branch you run:
1.123.85,2.43.5or2.44.1, or later. - Do not expose the component's API or UI to the internet without authentication in front of it.
Sources
- NVD: CVE-2026-118676
- https://github.com/n8n-io/n8n/security/advisories/GHSA-v9cx-v88r-42vw
- https://www.vulncheck.com/advisories/n8n-before-1.123.85-2.43.5-and-2.44.1-credential-permission-check-bypass