n8nPublished 30 Oct 2026NVD status: Deferred

CVE-2026-119408

n8n before 2.42.6, 2.43.x before 2.43.3, and 3.x before 3.0.1 contains a remote code execution vulnerability via deprecated Function, Function Item, and LangChain Code nodes running outside task runner isolation.

Componentn8n
Severityhigh (CVSS 8.8)
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published (NVD)2026-10-30
Affected versions
< 2.42.6
< 3.0.1
>= 2.43.0, < 2.43.3
read from the advisory text, followed where the structured sources say otherwise
Fixed in3.0.1
WeaknessCWE-653
CISA KEVnot listed

Versions, checked against NVD

NVD's record (status: Deferred) lists no affected versions of n8n for this CVE. The ranges above are read from the advisory text: neither a GitHub-reviewed advisory nor the CVE record confirms them yet.

NVD description

n8n before 2.42.6, 2.43.x before 2.43.3, and 3.x before 3.0.1 contains a remote code execution vulnerability via deprecated Function, Function Item, and LangChain Code nodes running outside task runner isolation. Authenticated users who can create, modify, or import workflows naming these hidden node types can execute JavaScript in the n8n main process.

What to do

  • Upgrade n8n to 3.0.1 or later.
  • Do not expose the component's API or UI to the internet without authentication in front of it.

Sources

Read more