n8nPublished 28 Oct 2026NVD status: Deferred

CVE-2026-118648

n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contains a stored cross-site scripting vulnerability because some webhook response paths, such as error responses and responses without headers, omit the…

Componentn8n
Severityhigh (CVSS 7.3)
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Published (NVD)2026-10-28
Affected versions
< 1.123.85
< 2.43.5
>= 2.44.0, < 2.44.1
read from the advisory text, followed where the structured sources say otherwise
Fixed in2.43.5, 2.44.1
WeaknessCWE-79
CISA KEVnot listed

Versions, checked against NVD

NVD's record (status: Deferred) lists no affected versions of n8n for this CVE. The ranges above are read from the advisory text: neither a GitHub-reviewed advisory nor the CVE record confirms them yet.

NVD description

n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contains a stored cross-site scripting vulnerability because some webhook response paths, such as error responses and responses without headers, omit the sandbox Content-Security-Policy. Authenticated members who can create and activate workflows can serve HTML that runs on the n8n origin, letting scripts act with the session of users who open the webhook URL.

What to do

  • Upgrade n8n to the fixed release of the branch you run: 2.43.5 or 2.44.1, or later.
  • Do not expose the component's API or UI to the internet without authentication in front of it.

Sources

Read more